Ozdat Home Feature Cars Ozdat Classifieds Event Calander Links Trade Link Tech Resource Merchandise Donate Web Mail
It is currently Sun Oct 22, 2017 8:30 am

All times are UTC + 10 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Sep 25, 2017 12:09 pm 
Offline

Joined: Mon Feb 13, 2017 1:03 pm
Posts: 1
I've wanted to get my hands on one of these for a while now (well... really a coupe, but they're stupid expensive) so when I found one that seemed to have a straight body I jumped at it.

ImageIMG_2451 by jones_fli, on Flickr

ImageIMG_1027 by jones_fli, on Flickr

ImageIMG_1009 by jones_fli, on Flickr

ImageIMG_1011 by jones_fli, on Flickr

ImageIMG_1012 by jones_fli, on Flickr

ImageIMG_20170212_195034 by jones_fli, on Flickr

Home sweet home

ImageIMG_20170211_173901 by jones_fli, on Flickr

Found some surface rust

ImageIMG_20170414_150736 by jones_fli, on Flickr

and some not-so-surface rust

ImageIMG_20170416_162810 by jones_fli, on Flickr

The thing didn't run very well when I got it and I narrowed it down to a problem with the original Hitachi carburetor. From a bit of research I determined it was not worth repairing, so I bought a cheap Chinese copy of a Weber 38/38 Outlaw DGES and made up an adapter bracket on my lathe.

ImageIMG_20170302_175536 by jones_fli, on Flickr

ImageIMG_20170302_211610 by jones_fli, on Flickr

ImageIMG_20170302_212030 by jones_fli, on Flickr

ImageIMG_20170304_191858 by jones_fli, on Flickr

I couldn't believe it, but as soon as I got it bolted down the thing fired right up and settled into a low, but steady idle! I tuned it as best I could according to the instructions but then noticed there was a hose not connected to anything which was causing a huge vacuum leak. I'm hoping once that's blocked off I'll be able to get it dialed in much better.

I've since started painting some of the interior black

ImageIMG_20170415_170611 by jones_fli, on Flickr

I've now found the tank has a lot of rust inside it (no holes though, luckily) and the fuel lines seemed to be blocked. I've made a replacement feed line and bought a KBS kit for de-rusting the fuel tank and plan to do that over the next few weeks. Once that's done the thing should be running well enough for rego.

Plans for the car are to fix the rust, paint it gloss black, bolt all the chrome back onto it, tint the windows, lower it on some nice wheels and enjoy.

(maybe a manual conversion at a later date if I find the bits cheap... or maybe a crazy engine swap of some kind, that seems to be how all my cars go)


Top
 Profile  
Reply with quote  
PostPosted: Wed Oct 11, 2017 10:19 pm 
Offline

Joined: Mon Apr 06, 2009 10:24 pm
Posts: 36
Look forward to following the progress.

_________________
1976 260C Coupe- Colour TBA


Top
 Profile  
Reply with quote  
PostPosted: Wed Oct 11, 2017 10:23 pm 
Offline

Joined: Mon Apr 06, 2009 10:24 pm
Posts: 36
Mine is still progressing slowly


Attachments:
x20170529_173103.jpg
x20170529_173103.jpg [ 1 MiB | Viewed 84 times ]

_________________
1976 260C Coupe- Colour TBA
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 10 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group