ozdat.com
http://ozdat.com/forum/

Datsun 1600 Speedo problems
http://ozdat.com/forum/viewtopic.php?f=27&t=34739
Page 1 of 1

Author:  johnstam [ Mon May 14, 2018 9:58 am ]
Post subject:  Datsun 1600 Speedo problems

Hi Guys,
For sometime now my '70 1600 speedo has stopped working, It used to occasionally come back but now has completely stopped.
The cable is not snapped, and the speedo still spins up when you turn it with a allen key.
I feel as though it has something to do with the pinion gear in the gearbox, maybe it has wron out?
The car has a 63A 5 speed and was wondering whether anyone has had the same problem and how to replace the pinion gear in the gearbox? Where would you find a replacement.
Thanks!

Author:  Nissanman [ Mon May 14, 2018 12:47 pm ]
Post subject:  Re: Datsun 1600 Speedo problems

You can get the pinion drives from Nissan Parts.
It is fairly easy to remove, just remove a 10mm lock bolt and slide it out of the transmission.
Attachment:
Late model extension housing.JPG
Late model extension housing.JPG [ 267.89 KiB | Viewed 98 times ]


Have you removed the inner cable from the sheath to determine it is still intact?
You don't hear of pinion drives stripping very often :?

Author:  green200b [ Tue May 15, 2018 5:12 am ]
Post subject:  Re: Datsun 1600 Speedo problems

I had the same problem in my old 200B wagon several years ago, having similar symptoms as you with regards to it occasionally working again. It ended up being the pinion drive. Look carefully at the gear. Mine looked fine at first site, but when examined closely it was found that the middle of the gear had stripped out just enough so that it would no longer work. I replaced the pinion drive and problem solved, I had a speedo again!

Page 1 of 1 All times are UTC + 10 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/